FANDOM


This is the talk page for discussing improvements to the The Mage's Treasure article.
  • General discussions not pertaining to the improvement of the article should be held in Discussions instead.
  • Put new text under old text. Click here to start a new topic.
  • Please sign and date your posts by typing four tildes! (~~~~)
  • Do not edit another editor's comment.

Revenant Lackeys? Edit

I have never had a Revenant spawn and be spawned together with other creatures (someone had added that he spawns with Skeletons). Can someone check this for me please? Whenever I've disturbed the wards, I've always only had the Revenant itself to fight. --MiyuEmi 14:48, November 25, 2009 (UTC)

It was a while ago, but with me not only the Revenant appeared, but also Skeletons of various sorts.--Mytharox 14:09, November 26, 2009 (UTC)
I've already promised, but I'm heading there with another character today, so I'll post on it tonight. My first time I had the Revenant and various skeletons as well. --Crackerjaquebox 14:20, November 26, 2009 (UTC)

The tombstone Revenants in the Forest all spawn with underlings. The Phylactery Revenants are always solo, perhaps these are the ones you are remembering?

No, I think I'm just getting lucky. My Revenants for the tombstones always spawn solo. I'll do another playthrough eventually and I'll see if being something other than an elf and a rogue and see if there's a difference. I might also see if activating the tombstones in the forest first make a difference as at this point, I've always activated the tomb in the ruins first and just grabbed the others on my way out as I have to pass them again anyway! --MiyuEmi 14:41, November 26, 2009 (UTC)


Revenant Spawns with Skeletons Edit

I have played through this section now 6+ times and I have never had a Revenant spawn with skeletons or other lackeys. I wonder whether or not this additional spawning is part of the PC version of the game only. I have the XBox 360 version of the game and have played through with a human noble, dalish elf, city elf and human mage and I have never seen the Revenant spawn with friends regardless of the order in which I disturb the wards. Just did a play through this weekend to make sure of this. Someone might confirm whether or not this additional spawning should be noted as in the PC version only. --MiyuEmi 08:46, November 30, 2009 (UTC)

Ah yes, that would make sense. Because I've been through it now as a mage, dwarf commoner and city elf. I tried it your way on the dwarf and elf and got the whole party both times. I play the PC version however. Kinda sad, but even Bioware admits to making the console "slightly easier". Can't blame em though, there's a TON more you can do with a keyboard/mouse than a controller. From everything I hear though, they did an outstanding job on the console interface and playability. --Crackerjaquebox 07:32, December 1, 2009 (UTC)

Difficulty could be a factor? I am playing on 360 as human noble rogue and the Revs have a posse of regular and 'yellow text' skeletons. They are making the fights significantly harder than any of the single revenants you encounter for the phylacteries, so I assumed it was linked to what difficulty you were playing. Pre-patch PC version was, ostensibly, insanely difficult though.--Bad bad badPhezzy 12:48, December 1, 2009 (UTC)

The Elven Ritual, bugged? Edit

I've followed the exact instructions here to do the Ritual but whenever I put a full jug on the altar and pray, the water evaporates and I'm left with an empty jug. I'm thinking something's wrong, since I was told that if you did the ritual wrong, a pair of scary monsters would appear. I've had them once out of the dozen times I've tried. Paladin Oor-Tael


This happened to me as well. I only had to fight the shades the first time, though; now, when I kneel before the altar, the water just boils away, so I can't continue. --NickBomb

If you don't have the tablet the water will evaporate when you pray. The tablet is in a sarcophagus down the hall (leave the room, first right then first left). When you do have the tablet the altar will respond different.

Don't make the same dumb mistake I did Edit

I used this guide to try and do this, but in my haste I didn't realize that the pool is called the fountain and I was dumping the water on the alter instead. I too only got the enemies to spawn once and then the Elven ritual quest went to my completed quest log as failed. Dont worry though, its still completable even after its listed as a dead quest in your log! -t

Bug Edit

I can't seem to disturb the tombstones no matter what I try, even after completing the Nature of the Beast quest. Is there a bug to this?

You need to look at the tombstone in the part of the Braecilian Forest where the Old Hermit is first. Then you can disturb the others. Paladin Oor-Tael (talk) 12:45, June 8, 2010 (UTC)

Serious bug in Elven Ritual Edit

I have Dragon Age on PS3 and I tried the ritual without the tablet, just sort of guessing my way through it. The shades arrived and I fought them off. After giving up trying the ritual, I left the area. On my way back out of the warewolf's lair, I thought I'd stop on back by the fountain to see if I could figure out the puzzle (I was trying to not look at spoilers here). Well I went up to the metal door, tried to unlock it with a few characters and when I turned around to give up, I instantly was standing in front of the spirit at the cutscene. I said maybe one line and was fighting the spirit, the skeletons and the shades all at the same time. When I defeated them, I realized I was in the area behind the metal door and I had access to the armor and codex. Well, here's the big problem with that, the metal door was still closed! So after figuring I'm just missing something and wandering around for a way to open the door, I finally gave up and shut down the game. So looks like I have to ditch that save game and do a lot of the temple all over again, because I hadn't saved in a while. Has anyone else heard of getting stuck behind the metal door?


That happened to me too on my ps3 console,i went near the locked door,then the cutscene played with the female elf-shade,and after killing the shades and the skeletons i was stuck in the room.

Make a Hard Save before entering the room where the ritual is done. That Damn Ingrid (talk) 04:55, May 7, 2011 (UTC)

No shades? Edit

On 360. There weren't any shades. I tried to get them by screwing up purposefully, you know, for exp, and nothing happened. The ritual went off without a hitch. I even left an offering, and nothing. I didn't even have to restart the ritual. The RITUAL ITSELF worked fine, though.NickTyrong (talk) 18:53, November 9, 2010 (UTC)

Hello! Hey, it's been a while since I played through this quest, like maybe years if I hadn't played since 2009 as it is beginning to feel like. However, I thought that I had been able to reunite the lost mother spirit and her son, as a quest option. But that doesn't seem to be the case according to what I've read here. So did I miss something about it here? Or am I not remembering events correctly? Are we or are we not meant to help them reunite? Thanks in advance to any proper help and/or answers!

Leo Star Dragon 1 (talk) 01:53, May 1, 2012 (UTC)

Shades = Zathrian's son and wife? Edit

Has anyone ever tried to first complete Zathrian's quest and then to go to the shade? If they are perhaps the boy and woman Zathrian has lost, the female shade may act differently to the Warden. It's worth a try perhaps. Saratje (talk) 23:14, December 20, 2013 (UTC)

I don't think much would change. These shades speak Elvish, a language which the modern elves are barely familiar with. Hence they couldn't be his wife and son. Viktoria Landers 23:19, December 20, 2013 (UTC)
Ah that is true, I mistakingly thought they were from a more recent era. I also just tested it now, it won't make a difference it seems. Saratje (talk) 23:34, December 20, 2013 (UTC)

Separating out "The Elven Ritual"Edit

The Elven Ritual should have its own page, since it has a separate entry in the quest log/journal, Brecilian quests. A separate page will also eliminate double walkthroughs in this quest page and in Lower Ruins, and redirect properly after recent paragraph rename to "Chestpiece walkthrough". But, my initial attempt at creation failed, since the name is linked to this article. Can an Admin assist in resolve this conflict? Thanks... --BlueOtter (talk) 17:48, February 16, 2014 (UTC)

Looks like there are two different similar redirect: Elven Ritual and The Elven Ritual. Whichever is the correct quest name, I'd suggest changing that redirect page into an actual article, and then the other one should point to that new article. (Clicking on either of those links will automatically take you to this article, but all you have to do is click on that redirect below the page name to get to it) Kelcat (talk) 17:49, February 17, 2014 (UTC)
Disclaimer: that is how I usually do it, though you may want to contact an admin directly to see if they think it should be done differently. Kelcat (talk) 17:51, February 17, 2014 (UTC)
Oh, right, I should have clicked on the link below the name. Duh, a Homer Simpson's moment. Thanks for point it out and the other redirect. Anyway, I went ahead and created the quest and fixed all the links out there. --BlueOtter (talk) 23:07, February 17, 2014 (UTC)

I fought out of order and have the plate gloves and plate boots. Now I go to were the helmet should appear and when I activate the tombstone, a puff of black smoke appears and I get some experience. No revenant. 70.176.11.183 (talk) 15:01, July 18, 2015 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.