FANDOM


This is the talk page for discussing improvements to the The Fade: Lost in Dreams article.
  • General discussions not pertaining to the improvement of the article should be held in Discussions instead.
  • Put new text under old text. Click here to start a new topic.
  • Please sign and date your posts by typing four tildes! (~~~~)
  • Do not edit another editor's comment.

Glitch? Edit

I don't know if it was just a glitch or what, but in the "Templar's Nightmare" (or whatever, that area with the kind of circular arrangement of rooms) place, there's a spirit door that I accessed just by standing near it. I don't know if it took me where it was supposed to go, but I definitely got warped to another area. - Ancestralmask 15:36, November 21, 2009 (UTC)

I'm not sure. I do know that there's a Fade Portal somewhere on the Templar's Nightmare level. And that you have to take it. These are able to be used regardless what "form" the player is in, and do warp you to a different area. Normally Spirit Doors will warp you into a small area (usually only a room or two) where you will be able to collect essence fonts. --Crackerjaquebox 09:25, November 25, 2009 (UTC)

Theres also another glitch in the Nightmares for example in Zev's nightmare he is being tested by the Antiva but I fought the people and cut ones head off and quickly talked to Zev before he auto-talks to me causing the scene to replay with the dead characters (the one that had there head off was just a headless body and was funny)

That happened with Sten as well. I don't think it's a glitch since at one point in the replayed conversation, Sten says "Perhaps my memory is failing, but I thought I told you two to shut up.", which he did. So it's probably just a part of the dreaming and is easily gotten around by simply leading them away from the location you found them. --Tobin 08:39, October 18, 2010 (UTC)

Please confirm Edit

I have only played through Lost in Dream twice. Both times I was transported into the fade, I lost 2 attribute points to all stats. Has anyone else noticed this? I'm also unsure, but I think there are four essence Fonts for each attribute, allowing you to gain back the 2 points lost, and gain an extra two per attribute. If anyone could confirm these two points I'd appreciate it. If they are true, I think it would be pertinent information for me to include in this walk through. Thanks, --Crackerjaquebox 09:30, November 25, 2009 (UTC)

Played through this yesterday on the 360, and I did not lose any stats. However, this could be a difference between PC/console version. I didn't check when playing through this quest on the PC... - Ancestralmask 17:06, November 30, 2009 (UTC)

Well, I do know that I am absolutely wrong about there being 4 of each attribute. I've been having a very difficult time tracking down just how many of each there are, but most reports say 20 total and a couple of the fonts seem to differ on class being played. Cunning, however, is universally agreed to have 5 fonts. Great......If you're a rogue, but for anyone else it's kinda BS. --Crackerjaquebox 07:35, December 1, 2009 (UTC)

Did you shapeshift before checking your stats? The form you are in affects your stats...

Complete! Edit

I am finally finished with this walkthrough. Feel free to add any contributions, and edit any mistakes you may find. I appreciate everyone's patience during it's creation. Sorry it took so long. --Crackerjaquebox 11:01, November 25, 2009 (UTC)

This is really good work Crackerjaque, I have a hard time writing paragraph long backgrounds for minor character pages, I can't imagine how hard it must have been to write all this. Good job. Pinkmullet 12:57, November 25, 2009 (UTC)

Checklist for Attributes...

The Fade "Weisshaupt" 1 Essence of Willpower(+1 Willpower)

The Raw Fade 1 Essence of Willpower(+1 Willpower) 1 Essence of Dexterity(+1 Dexterity)

Darkspawn Invasion 1 Essence of Cunning(+1 Cunning) 1 Essence of Willpower(+1 Willpower) 1 Font of Strength(+1 Strength)

Burning Tower 2 Essence of Cunning(+2 Cunning) 1 Essence of Constitution(+1 Constitution) 1 Essence of Magic(+1 Magic) 1 Font of Strength(+1 Strength)

Mage Asunder 1 Essence of Constitution(+1 Constitution) 1 Essence of Cunning(+1 Cunning) 2 Essence of Dexterity(+2 Dexterity) 1 Essence of Magic(+1 Magic) 1 Essence of Willpower(+1 Willpower) 2 Font of Strength(+2 Strength)

Templar Nightmare 1 Essence of Cunning(1+ Cunning) 1 Essence of Dexterity(1+ Dexterity)

Nightmares Edit

The Dog is just asleep, you only have to shake him awake. --DarkJeff 07:50, November 30, 2009 (UTC)



The warden need not free the companions. It is possible to go directly to Sloth after defeating the other demons without any companion. They'll join the party again when returning to the mage's tower. Of course they can be of some use to fight Sloth, and there is no real good reason to leave them in their nightmare,but freeing them is not mandatory. MUST should be removed from the article page Croquignol 02:02, January 16, 2010 (UTC)


On the nightmares, I know that for at least Alistair and Leliana, depending on the dialogue options you choose, they may or may not help you fight when you try to free them. Is this also true for other companions?


The mentioned glitch seems to happen in all companion nightmares. Sometimes the end-scene is not triggered, instead the dialog starts all over when you talk to your buddy. But this time without fight. Alistair's scene contains an easteregg when this happens: You and Ali are covered in blood and Goldanna is missing her head! Nevertheless she asks if you wanna stay for dinner ;) --Ladguru (talk) 15:21, August 21, 2010 (UTC)

List of essences Edit

I want to create a list of all the essences and their locations, so it is easier for people to track if they found all of them. Any help on this would be appreciated. Docnoq 17:04, December 1, 2009 (UTC)

I have posted the essence list on the main article page. I searched every area of The Fade and I believe I have found every essence. If my description of any essence location is inaccurate, feel free to clarify it.--Docnoq 19:56, December 1, 2009 (UTC)



I am adding those to the locations as well (parts of the fade) although it might be handy to have a place for an overview. See Fade Pedestal and the places section.--Mytharox 16:59, December 1, 2009 (UTC)
See also Fade: Essences and Fonts (I'll move some of your info there as well.)--Mytharox 18:14, December 1, 2009 (UTC)

shorter wt Edit

idk if some people don't want to read the whole thing (i dont, to be honest), its very long, so i just wrote down the order, etc, for a very brief read, maybe some people will want to use this instead of going through the entire walk through, anyway here it is, someone include this in the article if they want, or don't, i dont really care either way.


very brief, but everything is in the right order, if you see a wall of fire, pass it using the burning man form, if you see a mouse hole that leads to somewhere you want (very rare after the raw fade, used it like 3 times or something), if you see a spirit door, you have to be in spirit form to use it, and if there is a massive door, go to golem mode and throw a giant rock at it (the skill is called hurl i think)

get mouse, go through hole, kill thing, go through fade portal, come back to pedestal, go to burning tower, go to second floor, get burning man power, go to first, get cunning through mousehole in room, go to mages asunder, use fire shape to get past door, go up stairs, do second floor crap, get stone form, go up stairs, kill slavern or w/e, notice spirit door, come back for bonuses later if you want, go to darkspawn invasion, continue, get spirit form kill boss (some kind of ogre), go to burning tower, continue and kill boss, go to mages asunder, go to alchemical lab, use the spirit door, pass through, kill boss, go to the raw fade, use spirit door, kill boss, get your buddies, go to the middle, kill the sloth demon, done.

This is a poorly written block of text.


A brief walkthrough would leave out certain aspects like 'Benefits of shapeshifting to _____'. It would just be something like 'Go to location x and perform action y.' The above block of text isn't very descriptive or helpful, but a brief walkthrough would definitely benefit those who don't want to weed through the article text. --Ambios 17:20, December 31, 2009 (UTC)
During my (still ongoing) attempt at improving this page, I included a Quick Overview section that may fit your description of brief walkthrough. I imagine it can be improved, of course.FR 20:54, February 19, 2010 (UTC)

Healing Poultices Edit

Uh... since when do healing poultices not work in the fade? I definitely used them. A lot. - Ancestralmask 23:48, December 8, 2009 (UTC)



THey only don't work if you are in like eg, mouse form or shale form. But switching back to human form will heal you.The-loveable-rouge 18:37, February 5, 2010 (UTC)

Don't let him use blizzard Edit

Nearly every walkthrough I look at says not to let the sloth demon use blizzard. Is there some secret counterspell I don't know about or something? It seems like everyone knows this trick and it's so basic to all of them that they don't mention how to do it. I've been stuck on this part for two days thanks to some bad decisions on my part (no poultices left, accidentally killed Wynne) and I don't want to have to start the game all over because I can't leave this part. 207.171.213.97 07:35, January 3, 2010 (UTC)

Stun/knockdown/freeze, anything that would stop an enemy attacking (Dirty fighting for rogues, shield bash for warriors, winter's grasp for mage as a couple examples)
My tactic would be to move my people out of the blizzard area. When I begin the battle I make sure the ranged attackers (I like to keep only my main character in golem form tanking the boss, use golem's powers to taunt initially every time the boss changes form and if the boss uses a long-cast spell like blizzard, everybody else should use ranged weapons) are a long way away. As the battle continues, keep an eye on your ranged weapon users as they sometimes move nearer to get a better shot, or stop firing entirely. Keep them spread apart if possible, so that the demon can't catch them all in the blizzard at the same time.
With a Warden mage I had Morrigan in my party. We both have Winters Grasp, Cone of Cold, Force Field, and my Warden has Crushing Prison. Only triggering the spells manually, was able to lock Sloth down to where he barely moved the entire fight. The only hits he got in were at the moment he switched forms. Cone of Cold has a fast recharge on it and a nice long freeze so did most of the work, with the others used as needed until one of the two CoC's recharged, or a Force Field to give me time to recharge mana at a Lyrium vein or from potions.Gbrussell (talk) 16:18, August 1, 2010 (UTC)

Sloth Demon Edit

I counted 5 forms for the Sloth Demon, but this only says 4... looked like Orge, Rage Demon, Abomination, Arcane Horror and maybe the Sloth Demon himself? Not sure. I just know that I looked at this after I died the first time and thought "Okay, tough it out through four" only to find a fifth form waiting for me!

There are only four forms. He may have switched half way through one, then switched back. Coroxn 01:42, January 11, 2010 (UTC)
His life ran out on each of them. Maybe he switched to one form two times, but he never transformed halfway though a fight. Definitely 5.
Hmm. Your Actually Jogging My Memory Now...I'll Start Researching Today...Maybe there were five.....Actually, I think the Arcane Horror/Spirit Form May Have Been Used Twice. I'm Not Sure If I Even Remember It Or Not....Coroxn 13:33, January 11, 2010 (UTC)
I can confirm there are 5 forms. Also the walkthrough portion only mentions 3 forms. Jmjimmy 15:51, January 24, 2010 (UTC)

the other form you don't have is a shade.Icedeath 04:13, April 9, 2010 (UTC)

Glitch on the 360? Edit

I acquired every power, then defeated each mini boss, saving the one behind the spirit door next to Niall for last. None of them unlocked the pathways, but after retracing my steps and going through the fade pedestal that appears after every respective boss fight, the paths are unlocked.

Another 360 glitch? Edit

Everytime I rescue a party member from a nightmare, I have to run through their beginning dialogue again. Maybe this is related to my earlier glitch with the broken paths? Also, the apparitions have diappeared during the dialogue, they are disembodied voices.

The Same Thing Happened To Me. But Only With Wynne. Coroxn 15:45, January 14, 2010 (UTC)
This is currently happening to me with Wynne, but I believe it has happened with other party members. This should be noted in a "Glitches" section, along with a solution if anyone has come up with one.204.111.126.237 06:22, January 24, 2010 (UTC)
This is already covered in the glitches section, it's the generic "delays" glitch - if you simply walk away from the game for a minute or two you'll find that it resolves itself without having to talk to them. It's very annoying. I think it may actually be a memory leak as the longer the game has been running the more often the delays occur. Jmjimmy 15:48, January 24, 2010 (UTC)

Yeah, it happens with all of the characters, there is a delay from when you slay any demons and their new dialogue occurs before they vanish. If you try to leave it'll say can't do that during combat, if you try to talk to them it runs through the opening dialogue again. You just have to run around or wait for a little bit, not long!

Can't lvl up? Edit

Hey, I'm in the fade: lost in dreams and my xp bar says 5500/5500 but I'm not lvl'ing up :/


Is that supposed to happen?

edit: nvm, you can only level up when you're not a spirit and kill an opponent. :/

SecondVISION 16:43, January 27, 2010 (UTC)

im trapped Edit

Help. I'm caught in the fade. I have done all the rooms except templates nightmare. I can not move from the first section. there are 3 fade doors and 3 mouse holes, 2 of doors lead to the 3 door, and the 3 door leads to the 1 - mouse hole 1 and 3 are linked and mouse hole 2 lead to a small room, with something "cunning" I think, and then you can take the hole back. Can¨t do anything else, what must I do to move forward?

It sounds like you're in "Templar's Nightmare", in which case you need to make your way to the spirit door in the north west section of the map. See map here - it's the upper red block. Transform into Spirit and enter. That will take you to the bottom section on the map. Make your way through this section to the fade door, continue in one direction through the fade doors until you reach a new section (shown in the bottom right on the map) - the last room in this section has a mouse hole that leads to the daemon fight. Cheers Jmjimmy 18:08, February 1, 2010 (UTC)

no loot? Edit

On my second play i found a "fire crystal" on the corpse of a priest that i killed in a room with 2 Golems. i found it very strange cause i indeed remembred that there was no loot in my first play. Strange

I ran into this too on one of my first play-throughs (I had to do it a couple times my first go through). I don't remember exactly which part it was but I killed a couple Rage Demons and they had some health poultice on their bodies I was able to loot. It didn't happen again. So I would say this definately isn't normal but it can happen I guess.(forgot to sign the first time) Bandit-Behind-Bars 09:30, February 17, 2010 (UTC)
Just looted a Lesser Lyrium Potion off of a Lesser Rage Demon (again) in Mage Asunder. So this is the second time I've looted something in the fade. Bandit-Behind-Bars 01:17, March 4, 2010 (UTC)


Another poster, I got corpse-gall's from the Undead in Oghren's nightmare, so no loot? Not quite.

Possible "Teleport" glitch with shapeshift and doors Edit

I did this today by accident on the xbox 360 version.

I was walking up to a regular closed door while using The Burning Man form. As I reached the door, I reverted to my characters form.... and found myself on the other side of the closed door. Not sure if it was a one off thing, I might load up a save I have from when I was in the Fade and attempt to reproduce it, if I can I will try it on a massive door. Might be an interesting exploit to speed up this section of the game if you don't need to do as much backtracking. :D

99.229.88.196 18:26, February 5, 2010 (UTC)

I've experienced similar teleporting in the fade, though never through doors. More randomly from one end of the room to the other when switching out of a form. Jmjimmy 00:10, February 6, 2010 (UTC)
Come to think of it, I believe I have experienced those as well, I've yet to reproduce the door one though. Probably was a one off thing.99.229.88.196 16:24, February 11, 2010 (UTC)

Request: Walkthrough Edit

We need a walkthrough here on this site, with the Location of all the Essences and it's accessibility.

This is by far the Best walkthrough I've read regarding The Fade, not sure if it's appropriate to just copy-paste the whole thing here.

Please do take a look: http://social.bioware.com/forum/1/topic/66/index/517400/1#561556

help with the massive doors. Edit

I have the golem form, and went through 1 massive door in the southern part of the mage asunder and got to the massive door through the maze but when i tried to break it down it did not work. I went through the whole maze and killed the golems and mages; i thought maybe if i kill them i could break down he door, but nothing happen. is their a special way to throw the stone at the doors????? can someone give me an idea or a way to do it. -censored- hit me up its my cell.


I wouldn't advise posting that on a wiki site (or anywhere on the internet for that matter).... Lufos 03:20, February 26, 2010 (UTC)

Did you click on the door [in golem form]? Or activate its AoE spell, Hurl? I think there's a gigantic difference between the two options... NicKeL BreaD 23:46, August 21, 2010

(360 version) I am also having that issue, the golem form won't allow me to target the doors with the hurl ability. I tried aiming past the door but the golem tries to walk through it because he can't see the area. i am completely stuck and it's obnoxious.

When in Golem form, just right click on the door, (like you normally would to open it), and you will automatically use hurl to break it down 124.168.239.176 (talk) 11:35, September 22, 2010 (UTC)

I am playing the 360 version for the first time (used to play the pc version) and this helped out immensely! Thanks! I think I ran into a small glitch though. Right after you get access to the golem form there is a massive door right there that allows you to get back to the first room in the level. This door will not open no matter what I do to it. When I hit A it just says "cannot be picklocked" and hurl doesn't work either, obviously. So, yea, it doesn't stop you from continuing the game, but if it doesn't work your in for a long walk back. DeloreanFanatic (talk) 19:13, February 25, 2011 (UTC)

Companions are free but do not join the fight -.- Edit

Hi people,


I freed all 3 group members and thought they would join the fight against Mr Sloth, but I do have to solo him and they don't show up.

Does anyone know why?

Thanks.

78.34.246.116 04:03, March 9, 2010 (UTC)



Sounds like a glitch. You might have to reload, that's the only thing I can think of. It might be some version of the memory leak/delay glitch that happens if you play for too long. I've had all my companions disappear on me before too, but that only happened in Orzammar when I partook in some funky fast traveling.


It might not be a bug or any other problem. There is a chance if your companions' approval rating of your character is too low that they will not help you in the fight. It mentions this on the main page before detailing the different nightmares your companions will be stuck in. If I remember right if you choose certain dialouge options when freeing your companions from their nightmares they also will not help you in your battle against Sloth, I'm not sure if this is true or not since I've never had it happen with me. Bandit-Behind-Bars 22:53, March 9, 2010 (UTC)

Cannot shapeshift into mouse (PC) Edit

I get the mouse form right in the beginning and it appears on shapeshift thing underneath my minimap, however I can't activate it. I can mouse over it and highlight it and see the tooltip but I can't click it. I have no idea what's going on and I can't progress my game so I may end up having to start over. Anyone have any idea how to fix this or am I stuck forever.

Cannot Shapeshift into mouse (PC) Edit

I also have the same problem of not being able to shapeshift. and your description is the exact same as mine. anyone with any advice would be nice.

HEEELLLPPPP!!!!!! Edit

Hey! Okay, this is my second time playing through this quest, the first time I restarted the game because I was so stuck I couldn't get out! Can someone please give me a very detailed and simple outline of how to complete this quest? I am so confused and lost. I've looked through other guidelines and didn't find them helpful. Anyone that could help me would be much appreciated!

Did you actually read the main article The Fade: Lost in Dreams and the linked articles about specific areas and aspects? If you need more you will have to be a bit more specific because I cannot think of anything that is not described there. Unless you just mean something like this: Talk to everyone that will respond to find out what is going on. Travel to every location you can get to (there are locations in all areas that you cannot reach, and objects you cannot use, before you have gained a specific shapeshifting ability so you will have to revisit some areas later in the quest). Kill the main demon in each area (island) of the fade pedestal inner circle, this will give you access to the outer islands where you can go to save your companions. Finally go to the center island and kill the demon holding you all trapped in the fade. That's it. Boise66 10:24, April 6, 2010 (UTC)

I noticed a thing called "a hidden door" in one area of the raw fade (the area with the ship). I wasn't able to make any use of it. I may have overlooked something as I did not find anything on that in the walkthrough of the fade.

Hello! Yes, that's what I came here for, information about the "Hidden Door"! I remember being frustrated with it in 2009. Now in 2012 I don't remember what the solution is that I do recall finding here back in 2009. So what is the way to find that "Hidden Door" anyway? Please help everyone that wants to know! Thanks! Leo Star Dragon 1 (talk) 10:06, April 14, 2012 (UTC)

Enemy golems in the Fade lose interest? Edit

On the PS3, when I fight more than one golem at a time, sometimes one of the golems will suddenly stop attacking and stand hunched over, not doing anything. Is there some kind of glitch where if you take too long to kill a golem other golems will stop perceiving you as a threat? --Rival grace 18:30, May 6, 2010 (UTC)

It seems to be purely because of the size of the Golem - if it can't fit in to a place in order to get you, it just goes in to idle mode. It can also be caused by fighting multiple Golems at once or backing in to a narrow corner. 87.194.16.148 (talk) 23:32, September 29, 2010 (UTC)Smeep

Companions appearing but not fighting Sloth? Edit

I've freed my companions, and they even appear and do the regular dialogue when I'm talking to the Demon...but then they stand there while I get my ass kicked. Even if I switch to controlling a different character, the other three just don't fight at all.

Are your tactics set to make them do anything? 71.240.52.185 (talk) 01:16, July 5, 2010 (UTC)

Massive door Xbox 360 hurl ball failure Edit

Hey yea ive looked on the internet 2 see how 2 break open a massive door. I kno that u have 2 use the golem and use the skill hurl ball at the door. However that doesnt work for me for some reason. when i go 2 use the skill and position the target it either hits the floor right infront of the door or my guy justruns up to it and does nothing ive tried this many times and I cant break the door

Have you tried in click the door in the Golem form? The golem automatically uses Hurl in the door and never misses. --Rocketai (talk) 19:19, July 27, 2010 (UTC)

when i click on the door the golem simply states "it cannot be picked"

use the hurl abbilty just behind the door you want to open he will walk up to it but wont do anything then press A (xbox 360) and he should use hurl.

Use the dpad to select the door then press a

To open the Massive Doors. Edit

Just follow the ways to get all the forms and when you come to a massive door , click on it once or untill the golem hurls a rock to open the door.

                                  for ps3 = if the little eye icon isn't above the door = golem won't hurl. leave the room use a fade pedestal then return.

stealing: hardy's belt and silversmith's key? Edit

I was able to steal this from both morrigan and allistair- but nothing from wynne in their respective nightmares. is this intended or a bug?

Clean-up available.Edit

Due to a medical leave and LOTS of free time, I'm in a rather advantageous position. I can load a saved game at the beginning of this quest and go through answering various questions and such. My 3 companions are Wynne, Alistair, and Sten. Rather than going in and "cleaning up" the hard work already done, I'd prefer to know what specifics are wanted and I will go from there. Below is a sample rewrite for your review.

Lost in Dreams can be fairly confusing and difficult for some players. This quest line requires the use of several Mage abilities, such as Shape Shifting and Spell Casting , which may be unfamiliar to those playing other classes. This Page will go into specific details regarding these abilities, as well as various locations and enemies that can be challenging. For a brief summary and less detailed walk-thru see Walk-thru Summary . (A separate page to be created for those not wanting to read ALL the detailed pages.
Overview
Fighting their way up the Circle Tower , the Warden and company will eventually encounter an Abomination, possessed by a Sloth Demon, in the central chamber of the 4th floor. After a brief encounter, the party members are put to sleep, only to awaken in a domain of the Fade controlled by the Sloth Demon, who has placed everyone in a dream-like reality created to rob them of any motivation or desire. In other words, providing sloth for the Sloth Demon. A Magical ward, held in place by five Demon Lords in his hierarchy, surround and protect the Demon ruler. The Warden will have to travel through various sub-domains and acquire special talents and skills to not only gain access to specific areas, but to defeat the Demon Lords that rule them as well. Once this is accomplished, it's time to face the Sloth Demon, and escape the Fade.

--Tobin 11:14, October 18, 2010 (UTC)

Sloth Demon teleport glitch Edit

Well, after I fought 4 forms, the 5th one suddenly dissapeared. Me and my companions put the weapons down, I was however not able to do anything. No way to leave the island. After some desperate running around I saw the red dot on my minimap and then spotted the sloth demon somewhere far away floating above the abyss. No way in reaching it. Well I had to load and it worked the second time. --Araxiel 1911 (talk) 00:10, January 4, 2011 (UTC)

Glitch? Edit

Dunno if happened to somebody else, but in the first part of the quest (When you meet Niall) I was able to skip directly to the fight with the desire demon just by clicking past the spirit door (Then I got teleported). Anyone?


Good level to play at Edit

In case anyone wonders, I did the fade with a lv13 two-handed-weapon warrior. I found the whole area rather easy.

Please, help. Edit

The fade used up all of my health poultices. This caused me to be unable to proceed much further. I am at the venue where I'm supposed to get the golem power. Is there a way out of this? I have no party members with me yet. No health potions left.

Game breaking bug fight agaisnt Sloth demon Edit

Could anyone help me? each time I kill the third form of the Sloth Demon my game gets an error and closes.

Points Edit

Lot to read through here, I just skimmed.


2 points.


a) Had problems on occasion with Wynne restarting after we've dispatched all the demons, but never Morrigan. Surprised Morrigan is mentioned but not Wynne.


b) Once the demons have all been defeated it'd be nice to be able to access maps (as opposed to walkthroughs) that simply indicate where the attribute boosts are, as it is tedious to walk through everything again searching for the ones you've missed.


109.157.157.241 (talk) 20:07, November 23, 2011 (UTC)

Hashmarks on Fade Pedestal Map Edit

I'm unable to find out what the symbol means. I have 3 hashmarks with a 4th running through it. Is that the symbol for clearing a fade nightmare level? It reminds me of the 3 swords symbol on the first Guild Wars after clearing a mission with bonuses. I just don't want to miss anything when clearing these Nightmare levels.

Community content is available under CC-BY-SA unless otherwise noted.