This is the talk page for discussing improvements to the Legacy article.
  • General discussions not pertaining to the improvement of the article should be held in Discussions instead.
  • Put new text under old text. Click here to start a new topic.
  • Please sign and date your posts by typing four tildes! (~~~~)
  • Do not edit another editor's comment.

Serious Pathfinding Issues In Final Fight Edit

The fight against the "Ancient Evil" is made considerably more difficult and very annoying due to the stupidity of the characters, who cannot even find their own feet let alone their way through the obstacles that pop up. I constantly have to tell 3 people to just move forward to a location, then personally have to control and navigate the last one, who always ends up dead, because it always goes in the wrong direction and gets stuck in a dead end, and incinerated, unless I CONSTANTLY interfere, and just look on at what just happened when I finally manage to disable all statues, only to have the idiots stuck and killed off. And I never let anyone die. Or use stupid potions at every second.

This is ridiculous, even on normal difficulty. Bioware should get his act together, because this kind of bad programming is rather game-breaking. Incompetence.

I'm playing post-campaign, so I could not test whether the DLC fixes import save flags, like not thinking Nathaniel Howe is dead, and actually giving me the related quest in Act 3, or the Conspirators quest, or the one with the Sacred Ashes.

Such bugs are made even more annoying, considering the same type of bugs in Awakening. Howe lived, everyone at the Fortress lived, and I saved the city of Amaranthine, too. There was supposed to be some death cut-scenes if it wasn't successful, there weren't and, so everything should have an influence in DA2, but doesn't, due to the bugs.

--I only have issues with the final fight one time, which was that I forgot to equip people with items that have defense against fire. So I died and tried again. It was still hard and I ended up with only myself (Hawk) and Aveline left alive to finish the fight but the others lasted most of it before dying. I, too, was playing post-campaign but I plan on playing again with my warrior, who only just started the Deep Roads expedition and my mage, who isn't even that far. I am glad, though, that they include certain post-campaign things, like whether or not you killed Anders. (talk) 22:11, July 28, 2011 (UTC)Roselite

As, I've said, I did it post-campaign, with my level 27 Rogue, a bit over-powered, hehe.

I'm now playing with my 2-hander warrior, but I'm only in Act 1, and I'm going to do Legacy in Act 3, because I need some muscle, first.

Anyway, I took Varric, Bethany (Grey Warden, totally suped-up with the Warden Armor, I don't even waste attribute points increasing health, no, knowing what bonuses her Warden status grants), and Isabela (romanced and carrying coin+ items.)

I couldn't take Anders, unique dialogues or not, because I always kill him. Now, with a new campaign I just might, although I'm leaning towards Merrill more, her Wrath of the Elvhen ability might help me eliminate those pesky statue guarding shades in the final fight by sapping them while I can run around, making the fight more comfortable.

Or I'll just take Fenris to have a second 2-hander warrior. Double Scythe attacks will make for a nice, fast kill, me thinks.

--I might take Sebastian on the next one (my mage), along with Carver, Fenris (my mage's romance), since he can pick locks too. (talk) 21:42, July 29, 2011 (UTC)Roselite

Hmm... I just did this the other day and didn't have much of a problem at all. Just had to wait until the fire just passed, then keep Hawke just behind the fire, then run all the way up the next platform so that the companions have lots of room to join you. Though, I was on normal difficulty... might be different on Nightmare if they are being idiots and running through lightning even when Hawke didn't. AbsolutGrndZer0 (talk) 05:46, November 5, 2011 (UTC)

Genlock Alpha Edit

WTF is up with the Genlock Alphas? Have they been on steroids or something since DA:O/DA:O-A? I mean seriosly, I saw them and I'm like "THAT'S a Genlock Alpha?" (talk) 12:59, August 4, 2011 (UTC)

Notes edited & photos added Edit

I have added 3 screenshot montages to the Photo page showing the banter available in Legacy between Merrill & Varric Tethras and between Merrill & Fenris. The Notes section for Legacy has also been edited to reflect this.

This is my first time editing / contributing to this Wiki .. I hope I did this correctly.
Merrill Varric Legacy Dialogue 2

Banter between Varric & Merrill in Legacy

Merrill Varric Legacy Dialogue 1

Banter between Varric & Merrill in Legacy

Merrill Fenris Legacy Dialogue

Banter between Fenris & Merrill at beginning of Legacy

Jghyers (talk) 05:48, September 13, 2011 (UTC)

Scaled Uniques vs. Level Up? Edit

So, I noticed this doesn't list the unique items available in this DLC yet... though some are able to be found on the Wiki. Also, does anyone know the scales of the items? I read that their stats are based on when you acquire them (which confounds me, why didn't they make these unique items Improve with Level Up?) AbsolutGrndZer0 (talk) 05:43, November 5, 2011 (UTC)

All the information should be in here:

Hope it helps :) Mr Afk (talk) 11:02, November 5, 2011 (UTC) (darn thing keeps signing me out)

Ive downloaded "Legacy" but even tho it says its been downloaded the griffon statue dosent show up in any of my houses on any save files. All of the achievments are on my console and on the main screen it says it's part of the DLC that have been downloaded...Please help. How can I fix this????

Giffon Wont Appear, Please Help! Edit

After downloading "Legacy" from Xbox Live the Mementoes from The Past Griffon statue won;t appear in any of my homes on any of my save files. It says its downloaded, and ive downloaded it again. I even have the achievments avaliable in the Achievement page. But no Griffon. And im unablbe to play the DLC. Please help.

Friendly Hint Edit

If doing this for the first time side with Larius and do "Riannon's Floor" rather than with Janeka and get stuck with "Daneken's Floor". The former is fairly easy to work out, the latter is a trial of trying this one then that and finding still no solution and going mad with frustration, until you give up and look for an answer on the Net. There is just too many resettable switches and no obvious reason why pressing one rather than another is the right answer, and forgetting what you have done in what order that has failed already, and finding you are just returning to the same state as you were in, half hour previously, for the umpteenth time. Unsure what the designer/developer was thinking of.

Community content is available under CC-BY-SA unless otherwise noted.