FANDOM


This is the talk page for discussing improvements to the Bugs (Origins) article.
  • General discussions not pertaining to the improvement of the article should be held in Discussions instead.
  • Put new text under old text. Click here to start a new topic.
  • Please sign and date your posts by typing four tildes! (~~~~)
  • Do not edit another editor's comment.

Sophia Dryden dialogue glitch Edit

Unsure if this is a glitch or not, but the other night I had Sophia Dryden in Soldier's Peak seal the veil before we did what she wanted. The exact second she finished sealing it it jumped back to the beginning of the conversation where you first find her beginning with "Stop, this one wishes to speak." Any ideas on this? Any other experiences? - WeHeartKatamari 15:04, November 11, 2009 (UTC)

I had the same problem except it was prior to her closing the veil and once the conversation finished she was still standing and casting but she and I were now where you first meet her. I could go back to the other room and kill the demons spawning but they were not going to attack her so if I wanted I could have probably just waited there until the event finished. I think this may happen if you exit out of combat prior to the next wave of demons spawning and you talk to her but I am not sure. -Goblinlordx 05:41, November 12, 2009 (UTC)

Unlimited attributes Edit

Kind of a exploit/glitch on the pc version you can add attribute points click "Reset" then take away from whatever you added to Example: Mage adds 3 to str clicks reset uses < button on str and gains 3 more points, also if you do this while an attribute is at 2 then add 3 reset take away 5 then add (it will revert to 2 and you will still have 5 points) those points to it and reset and take away again you gain extra attribute points. This proccess can be repeated as many times as you want.

Bodahn cutscene camp glitch? Edit

I had a glitch in the beginning of the game. After Ostagar/Flemeth and Lothering there's a cutscene where you dream about the arch-demon, and you have a little chat with Alistair. This camp differed from my earlier visit there - I camped between Flemeth and Lothering to dump stuff in my chest - as the chest was gone.

Bodahn, however, was not. The two Tomes he sells were available, and I bought them. Yes, I did runscript zz_money richbabyyeah, cause fuck money.

Anyway, when the 'real camp' came back, chest in place and all that, Bodahn had the same two tomes again. I have not tested this further.

Note: This is not a glitch. If you purchase those books the first time at camp, the next time you return, he will have them again.

Glitch in Human Noble Origin Edit

Last night i started a new char: Human Noble warrior, It was all good up to the point where I fight a mage and some other baddies in the main hall, I spoke with the main guard dude, but when i went to exit the door towards the larder, It was locked!! This is specially frustrating because in my first playthrough I did this entire segment without any problems. I have searched every inch of the castle TWICE, I reloaded to the part where the attack begins (when you wake up)but nothing works , Guess i'll have to start all over again!!

I had the door locked as well before. When I redid it from the moment my character woke up, the door was this time unlocked after the battle. It should be unlocked after the battle is done, but it seems to glitch a lot as I looked this up on the internet and found out many had this problem and had to redo this part. The door has to unlock once the battle is over. Metus 11:04, December 10, 2009 (UTC)

Quest Glitch? A Paragon of Her Kind Edit

I finished 'A Paragon of Her Kind', but it still says that I need to deliver the crown that Caridin made. King Harrowmont is already wearing the crown and it's no longer in my bag, but the quest remains active and unfinished. I play the PC version. Metus 11:00, December 10, 2009 (UTC)



Shale Glitch Edit

Shale apparently becomes glitched at some point in some games where all the dialogue you can get with her is the starting dialogue when you find her at Haven. Then you end up at some point off the map...

Merged Information Edit

I've just added a whole bunch of info from Bugs, but I'm not really familiar with a lot of this information, so it may need further pruning. Loleil 02:24, January 17, 2010 (UTC)

Warden Commander Armour Edit

I have been exploring the Anducan caves when I saved and shutdown the game . When I came back and restarted the game, my main Character (Female Noble) came back naked. She not only had none of her armour on, but it was gone from inventory as well. All the other characters were fine, except the main character. I loaded from an earlier save and the same thing happened, Naked as a jaybird. Anyone else have this problem. Now I have to make my way out of the caves Naked.

It sounds like your Warden's Keep DLC did not load properly. Either authentication failed or the servers were down. Make sure you're logged in before loading the game and see if you have your gear back. -- tierrie talk contr 01:56, January 28, 2010 (UTC)

Game Freezes (Recoverable) Edit

On my PC running Windows 7 Ultimate 64-Bit, every now and then, the game would freeze. But I could always recover using either of the following methods:

  • Press Ctrl-Alt-Delete to bring up the Windows system menu. Then press Escape to return to the game.
  • Alt-Tab to another open window. Then Alt-Tab back to the game. In my case, my open window is my web browser, which is tuned in to this website.

Has anyone else experienced this problem? --Jargonz 05:45, February 11, 2010 (UTC)

Templar Armour Glitch? Edit

I recently finished Dragon Age Origins with a Female Elf, Warrior, from the Denerim Alienage (on Xbox 360). I've never had any major problems except one. The moment I find decent armour better than what I have equipped I upgrade (as we all likely do). I did this in the Circle of Magi quest, cleansing the Tower so to speak, and equipped her with Templar Armour. Unfortunately it didn't equip properly and she wears it in reverse basically. Arms (if covered by Armour) are outstretched (if weapon is drawn) backwards and real arms (invisible due to armour) are in normal place with equipped weapon in front of character. At the time of playing I equipped it on Allistair which worked. I reloaded an earlier save and shut down the console but it didn't help.

I know this isn't a major issue but to any wanting to use a female Elf and make her a warrior, you may not be able to use the Templar Armour. This 'bug'/Issue was discovered mid Febuary. I added a similar explanation to the templar armour page, but if this is known and not needed then by all means delete this message.

-Do not wish to become a member-TY!


Regarding the Ancient Elven Boots GlitchEdit

There is a mod that fixes this glitch. Should I reference it and post the link? JKPackard 04:26, March 2, 2010 (UTC)

Maybe internal link to a mods page? Jmjimmy 05:27, March 2, 2010 (UTC)

Minor Inventory Glitch?? Edit

Just experienced an inventory glitch in Ostagar. I tried to find this glitch on the wiki but was unable to. However, maybe I was just to dumb and before messing up other pages I wanted to ask if others have experienced this as well and if they think this is a glitch:

I am on PC v1.03. Whenever a companion is removed from the party automatically (like Soris at the end of the City Elf Origin, or Daveth and Ser Jori after the Joining) I have all their items in my inventory. So far so good. But I also have two items their that are strange: One is "Arrows" the other "Bolts". Just like Fire Arrows or Ice Bolts but without any special features. Apparently I ended up getting their default ammuntion as regular inventory items. I can even equip the things parallel to my sword. Now that really look strange.

So, Question A: Can anyone confirm this behavior? I can repeat it when making sure that Daveth and Ser Jori have Ranged Weapons equipped before entering the joining.

Question B: Is this worth mentioning as a glitch? I mean the fix is simple. Just destroy the items.

Pp2009 (talk) 06:41, June 1, 2010 (UTC)

  • I've seen this too, but it didn't seem like a big enough issue to mention. You basically get two oddball placeholder items that aren't worth anything and can't be used by you. The fact that you get their stuff at all is actually an improvement. At release, whatever they had on them became inaccessible after the joining (same with Human Noble's mom), so I always had to remember to strip them of everthing before losing access to them, especially if I upgraded their default stuff. Servius (talk) 19:54, June 1, 2010 (UTC)

Possible Fix For Out Of Place Body Parts For PS3 Players Edit

Yesterday I was working on The Nature of The Beast quest and upon entering the first level of the Werewolves' Lair, my main character`s neck became crooked or tilted to the left permanently. I tried everything I could think of to fix the problem while in the game but nothing worked so I finished out this quest with the problem. After finishing this quest, I went back to Camp and saved my game. I exited the game and I decided to delete the game data from my PS3 and re-install it as I've read elsewhere that doing this can sometimes solve problems. Anyways after the re-installation of the game data, I went back in and loaded my saved game in Camp and lo and behold my main character's neck was back to normal, all straigtened out. I wanted to share this information as I've read about similar issues on this web site and others. Doing this procedure may be a fix for this type of problem and it doesn't delete your saved games nor does it delete the trophies you've already earned on the PS3. --Chris McCallum 12:39, June 18, 2010 (UTC)

Avoiding the darkspawn trophies' bug Edit

According to the discussion here, these bugs can be avoided in several ways:

- Saving before the final battle (most do at the elven allenage), beat the game, then reload and go through it over and over again until the trophy pops.

- Deleating the game data (not save data!). Beware this will disinstall any DLC you previously had installed, but you can still re-download them again from your PSN account. Now you have to run the game with no connection to the web, so that you can't download the 1.02 patch, then install the game data. This will downgrade your game to 1.01 (wich is a little bit unstable in some points, so beware of freezes/crashes), allowing you to get the trophies normally. If you had a save with the uses DLCs, it won't be checked.

These methods are still to be experimented and confirmed...please help us figure this out! I can say the second one worked for my Grey Warden trophy, and a lot of people say thy got their Blight-Queller with the first. --Kimerik (talk) 20:03, June 23, 2010 (UTC)Kimerik

A Paragon of Her Kind bug. Edit

I chose Branka's side during the A Paragon of Her Kind quest. Killed Caridan and got achievement. Then I reloaded the saved game from before the conversation with Caridan. Now, it just doesn't matter how the conversation goes, the outcome is always the same, whatever the NPCs say: I have to kill Caridan and side with Branka. PC version, 1.03

another inventory bug Edit

All items except crafting and crafted items disappeared, along with all but a handful of plot items. I'm not sure I can trace the cause, it was around the time I got Morrigan's ring and the first time I donated runes and coins to the Allied chest. I was running "D" and "K"s quests at the same time, and all Love Letters vanished before I could get the last one.74.176.34.144 (talk) 02:03, July 12, 2010 (UTC)

The Dump Walk Glitch Edit

Has anyone had this glitch where your character still has there weapons out then a cutscene happens and your character is stuck in a crouching position?

Spoilers Edit

I'm wondering when the spoiler template should be used, since the article contains spoilers. A spoiler tag at the start of the article would work fine. --D. (talk · contr) 12:46, September 16, 2010 (UTC)

quest/map or something else bug. Edit

Acquired the Unintended Consequences Quest. Came across the Trickster Whim, killed him off, no problem.

Sometime later, I get the encounter again - only he is already dead. Check my journal, it is not completed, no Chantry board recognises me. I thought this might have been related to the glitch where sometimes a cutscene will play twice.

I had kind of forgotten about it, but after some hours of playing, I have actually come across it again. Anyone else had this?

Attack speed bug? Edit

I play an Elf rogue. I went the dual wielding spec opting to get momentum, and stacking that with Haste. Alas when I finally got Wynne to get the spell haste, when I used the two sustained spells in combo, it made my attack speed MUCH slower. I don't know if this is a bug, or if they just don't want you to attack to fast. (I am pretty sure swift salve stacks with momentum)


would you class glitches like the money or xp glitche cheating i will thank any answers send them to cjbeatties talk page

ranged critical chance bug? Edit

a user placed the following question on the main page, I have moved it to the talk page

Sorry, I don't know where else to ask, I am a ranged rogue using the spells Tainted Blade, Aim and Song of Courage... While I was fighting in Redcliffe I had a crit chance of 22.5% and after the battle I took a look and my crit chance is 18.00%, I haven't changed any of my gear or spells... I cant imagine why it would change on it's own, is this a bug?

Did you turn off your substained talents during the battle and turned them back on later? because aim doubles crit chances only when it is activated, so if you activated song of courage before you activated aim, you would have more crit chance then if you activated aim first.--Schrödingercat (talk) 14:46, December 19, 2011 (UTC)

Codex Exp. Unrecieved Edit

X360: For me, unable to receive experience for all codices. I am lv 10 Dalish. It worked fine until recently. Result is the same in all map regions (well, i tested 3 different regions).UpsideDownSpinningKick (talk) 17:31, January 23, 2012 (UTC)UpsideDownSpinningKick

Cleanup ruminations Edit

This section refers to the player being able to simultaneously romance Leliana and Morrigan as a glitch... but I think most would agree that it isn't? So I'm wondering, is the dialogue bugged or something, or can this section (and any potential others like it) be deleted? --Sharwyn (talk) 01:28, June 22, 2012 (UTC)

Well, I went ahead and took the liberty of removing it. Also going to move some entries that could be classified as exploits to the Exploits (Origins) page. If I am in the wrong, feel free to administer forty lashes with a wet noodle. The whole page is in need of a major overhaul anyway. --Sharwyn (talk) 01:08, June 23, 2012 (UTC)
Going to continue talking to self as I work on the page. Several of the entries here are continuity errors, which I wouldn't really consider glitches- not bugs in the game itself, just oversights in the writing. For example, the epilogue mentioning Zevran's lover being female even if you romance him as a male Warden. Perhaps there should be a separate page for continuity errors? In the meantime I guess I'll make a separate section for them. --Sharwyn (talk) 19:29, June 23, 2012 (UTC)
In the process of moving bugs to their corresponding character/quest/item/etc. pages where applicable. I figure since pretty much everything in the game can go wrong in some way, it's redundant and messy to attempt to list every single possible bug on this page- also, people seeking solutions to specific problems will probably be more likely to check those pages than this one. --Sharwyn (talk) 22:03, June 24, 2012 (UTC)
Thank you for helping out! I never checked that page, but I think it was always intended to be about more general bugs, or one that can be applied to several articles (e.g., healing bugs), so the whole walkthrough to fix it can be linked on this page rather than copy/pasted everywhere.
Regarding Zevran's romance, it's noted on his article. A continuity error article would be a good idea (the topic has been brought before). I'm not sure what kind of content would go there, since I assume most of it would be related to lore or storyline continuity errors rather than an oversight (assuming) by the developpers, although I don't really see a problem with both being combined at the moment (I suppose they should be separated by sections). ··· D-day sig d·day! 22:51, June 24, 2012 (UTC)

I got a slight problem,i normally played on a SONY VAIO, now when i switched to my new Alienware 14 laptop and wants to play Dragon Age it wont find my character save? I cant press load game

Moving speech triggersEdit

Playing the Ultimate Edition retail with the latest patch, though I remember a similar issue a long time ago with a vanilla retail copy of Origins.

My character is triggering conversations where it shouldn't be triggering them. Like Teyrna Eleanor initiating a conversation with me in the Castle Cousland library or, more annoyingly, being told I can't go into the army camp at Ostagar every time I get within five feet of Ser Jory or the Quartermaster and then actually being able to go into said army camp without that same NPC stopping me. Of course, this means my party is being teleported around maps and making the game unplayable in places.

This has only started happening with this character, others have been fine but last time the problem transferred to all further characters and required me to reinstall the game. I don't want to do this as my gaming rig is not constantly connected to the internet and doing so is a real hassle. Help? -hashtalk 08:23, November 7, 2014 (UTC)

Combat Bug Edit

There seems to be a bug in the combat system. This does not occur 100% of the time and I am uncertain when this problem started and what caused it. I have tried looking online yet have not found anything related to my problem. The problem that I have is sometimes during combat whatever attacks I or any of my companions inflict does 0 damage, with no damage dealt counters displaying as well. However enemies attacking us are still doing damage at said point. After a few seconds all the damage that was inflicted during this time all is applied at once showing multiple damage amount marks on an enemies head and their HP being drained instantly. I would also like to add that any abilities for example a knockback will not knock the enemy back until a few seconds later similar to the damage issue.

I would like to mention that I have many mods installed, it may be possible that a mod is causing the problem but knowing this problem does not happen all the time, trying to disable all the mods and activating one by one to figure which one would take forever. So if possible if anyone has encountered this problem or has an alternative solution to fixing this problem which does not involve hours of countless testing please help me resolve this! Thanks again in advance! —Preceding unsigned comment added by 211.144.0.1 (talk) 16:40, October 11, 2016

I don't really have an idea how to find out without much testing (and haven't heard of this bug before, neither). But perhaps I might help you with reducing that time.
If you have a mod managing tool, which I highly suggest with a high number of mods, it would be easy to disable all mods at once. The first step then should be to test without any mod. If the error remains, try a new game (in other words: a "clean" save). If encountered again, you would know, it has not to do with some mod.
If you're bug-free without mods, I would re-enable the mods in groups. Start with gameplay and effect changing mods, first of all mods that alter combat mechanisms. Those would most probably be the culprits. If the bug now already occurs, you can enable the rest of your mods without risk. But keep in mind, which ones caused the bug.
Next step would be to look on those mods' pages and their discussions, if any bugs are known or people talk about conflicts. Perhaps you find a solution there. If not, then you would have to test intensively with that – hopefully – small number of mods you've kept in mind. Try one after the other, not cumulative, each one separately. If nothing happens, two at once, to see if it's a conflict.
That should spare you some time.
After combat changing mods, I would try dialogue/party related ones. Ability and skill affecting mods perhaps next. And tell us here, when you know what it was. (And sign your post next time. Icon wink CompleCCity (talk) 20:28, October 11, 2016 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.