FANDOM


This is the talk page for discussing improvements to the Bugs (Dragon Age II) article.
  • General discussions not pertaining to the improvement of the article should be held in Discussions instead.
  • Put new text under old text. Click here to start a new topic.
  • Please sign and date your posts by typing four tildes! (~~~~)
  • Do not edit another editor's comment.

XBOX Patch Edit

Does anyone know if a patch for the XBOX 360 version of this game is forthcoming? --MiyuEmi (talk) 17:26, March 25, 2011 (UTC)

Champion Armor misses runeslot Edit

I have a problem with Anders' companion armor. I got his 4th armor upgrade, which gives him a runeslot, then went to do his personal quest "Justice" in which he receives his new outfit. Upon gaining this new outfit, the runeslot (and the rune in it) is lost and cannot be regained. Apparantly you can only "fix" this by doing the quest "Justice" first and get the 4th armor upgrade after you received the black outfit.

The Exiled Prince Achievements Edit

I don't think the fix listed here is working. I only recently installed my Dragon Ages 2 copy and at that point I downloaded the DLC (two weeks ago). Can anyone confirm that uninstalling and then reinstalling this DLC does correct the achievement issue on this? --MiyuEmi (talk) 07:13, March 28, 2011 (UTC)

It's my understanding that just (re)installing the fixed DLC doesn't make the Achievements show up -- you have to earn them again. --Morgan-wolf (talk) 18:56, March 29, 2011 (UTC)

I've actually played through Sebastian's quests twice and they're still not working, even with a new download of the DLC. Have you been able to have them work in a playthrough? Suppose it doesn't matter though as I'm ignoring him due to the bug I'm reading about with the defence lowering he brings with friendship etc. --MiyuEmi (talk) 15:53, March 30, 2011 (UTC)

Life Ward Potions Edit

They dont work for me. Anyone else see this?

Shield Bug Edit

I've tested this supposed "Shield Bug" where reequipping a shied is supposed to permanently add to your armor rating on my PC version. I've done this with a few different shield, but my armor rating has yet to increase any more than the armor provided by the shield.

I've tried this as well. I saw my Armor Rating decreased the first time I unequipped & reequipped Aveline's Shield, but nothing seemed to change after that. Her total Armor Rating decreased that time I and never went down or up again.
Fycan [fahy-kan] @ 03:35, March 31, 2011 (UTC)

I had this bug occur with a weapon (staff) in the 360 version. Switching staffs from the "Voracity" (which has the bonus 1 mana per health for blood magic) repeatedly when fighting enemies who are immune to fire has caused my blood magic health/mana ratio to be reversed. Casting fireball now takes 54 health while blood magic is active (normal ratio with no bonuses would be 10 health). If I equip the "Voracity" now I am unable to cast at all as the damage now interrupts my casting. Possibly a bug with the autosave since loading my last save before the autosave fixed this problem. There were 6 autosaves after my last manual save which was about 2 hours previous.

General Section replaced with Hardware & Software Related Edit

I've removed the General Section because most of the bugs listed there belong to one of the Category already provided. With only exception being ps3Icon ps3's hardware and software problems, so I changed its name to Hardware & Software Related instead.
Fycan [fahy-kan] @ 03:31, March 31, 2011 (UTC)

Companion thrown out of battleground Edit

It happened during the 1st bone pit mission fighting the 2nd dragon. Somehow Isabella got in an inaccessible part of the cave underneath the battlefield, without a way back. It's my 2nd play-through (on PC) and the 1st time something like this happens. Ladguru (talk) 21:33, April 11, 2011 (UTC)

Multiple Debilitating Poisons a single target Edit

On the PC using 2 or more Debilitating poisons against a single target by applying it to companions weapons causes the enemies damage to severely increase. I found this out when I started to try and stack poisons against the High Dragon. I did several tests and took screenshots as example. Normal: [1] After using poisons: [2]. Both are dead on hits, the 2nd attack was offcenter and still did 150+. --PvtNiss (talk) 10:39, May 22, 2011 (UTC)

After testing more it seems debilitating poison simply is bugged on its own. It's increasing the damage of everything it touches! --PvtNiss (talk) 11:07, May 22, 2011 (UTC)

Varric random appereance Edit

(xbox) Many places I go Varric follows even though he isn't in the party. Merril's house, Hawke estate, etc,. Did anyone else have this problem?

Cast unknown spells/abilities Edit

PC patch 1.03, can someone confirm if this bug also appears on xbox/ps?

When spending ability points at a new non-passive/upgrade ability (only sustained and activated abilities), the icon is places in the action bar, not applying this chance (back button) causes this spell to still be there in the actionbar, however the action bar's tooltip will become the text 'null', and when the menu is closed, the ability will disappear. If you however move the ability to a new slot on the action bar, the abilities isn't removed, and you can cast/use the spell/ability without having it learned. The spell/ability will not be available through tactics.


Wounds of the Past doesn't need Blood of the First active? Edit

This may be a result of the most recent patch, but after giving Merrill a tactic to use Wounds of the Past when 4 or more enemies are clustered she will do so even though Blood of the First is not active. She does have a tactic to turn that on when her Mana drops low enough however. Could someone test this? This is happening on the PS3 version, could be on the others too. --Dracowrath (talk) 17:16, May 22, 2012 (UTC)

i found a very strange xbox bug. i made a female rouge with lady elegants hairstyle but white in color. when i started the game bethany and carver had each others hair. this makes it almost immpossible for me to look at them for they look both hidious and hilariuos. any clue how to fix?

Fools Rush in Edit

Isabella high town night. Bug is not only for PS3 and XBOX. I'm on PC and its doing it for me!

Clicked loot to fast before she spoke and then cannot enter the chantry doors. First time she followed after I killed all the baddies outside, second time no such luck. Ive checked my saved games back and unfortunately the save is right after I've already looted the bodies for the letter. Is there a PC Patch I'm missing that could help? :)

Hits But No Heals Edit

I have hit a bug. I can not tell if it is from the vanilla game or a mod issue but record it here in case someone has information or it may help someone else.

I was on 'Offered and Lost' (not sure if that is significant) with Varric, Merrill, and Anders. Doing ok when I notice Anders' has taken a hit or two so tried to heal him. His heal spell was used, it didn't change his health level. Time and again a health potion was used, they'd grey out showing they had been used and was now in cooldown, but again, Anders' health level didn't budge. Took me 3 reloads to keep him conscious throughout the scrap. Not encountered it previously so no idea why it showed then.

Community content is available under CC-BY-SA unless otherwise noted.